error with deployment Spfield lookup [Resolved]

Jun 27, 2012 at 10:31 AM

Hello,

 

I'm Nicolas and no speak very well english.

i have a problem with the deployment of SharePoint Filtered Lookup Field on my sharepoint 2010 enterprise.

I get the error :

This solution contains invalid markup or elements that can not be deployed as part of a solution in sandboxed. The validation of the solution manifest for the solution "5dcda1dd-48f6-2183-b330-978a1c891baa" failed, manifest.xml, line 6, character 4: The element 'solution' in namespace 'http:// / schemas.microsoft.com / sharepoint / has invalid child element 'TemplateFiles' in namespace 'http://schemas.microsoft.com/sharepoint/'. List of possible elements expected: 'FeatureManifests, ActivationDependencies' in namespace 'http://schemas.microsoft.com/sharepoint/'. 

when i try to activate this solution.

Coordinator
Jun 27, 2012 at 10:44 AM

Hi Nicolas, this solution is NOT a sandbox solution, but a Farm solution.
So, you have to install it using powershell:

Add-SPSolution -LiteralPath <Path_to_wsp>

Regards

Jun 27, 2012 at 11:50 AM

Hi PeppeDotNet

thanks for your response, but with the comand Add-SPSolution -LiteralPath <Path_to_wsp> i get the error:

PS C: \ Users \ administrateur> add-SPSolution-LiteralPath c: \ Dev4Side.SP2010.FilteredLookup.wsp
Add-SPSolution: Operation is not valid due to the current state of the object.
At line: 1 char: 15
+ Add-SPSolution-LiteralPath <<<< c: \ Dev4Side.SP2010.FilteredLookup.wsp
+ CategoryInfo: invalidData: (... Microsoft.Share dletAddSolution: SPCmdletAddSolution) [Add-SPSolution], InvalidOperationExcep
tion
+ FullyQualifiedErrorId: Microsoft.SharePoint.PowerShell.SPCmdletAddSolution

thanks
Coordinator
Jun 27, 2012 at 9:38 PM

Try to include your path into ""

Like this:

Add-SPSolution-LiteralPath "C:\Dev4Side.SP2010.FilteredLookup.wsp"

If you get the same error, try to follow these instructions to clear owstimer cache:
http://tomblog.insomniacminds.com/2008/07/30/sharepoint-internals-clearing-configuration-cache-caveat/

Regards

Jun 28, 2012 at 9:30 AM
PeppeDotNet wrote:

Try to include your path into ""

Like this:

Add-SPSolution-LiteralPath "C:\Dev4Side.SP2010.FilteredLookup.wsp"

If you get the same error, try to follow these instructions to clear owstimer cache:
http://tomblog.insomniacminds.com/2008/07/30/sharepoint-internals-clearing-configuration-cache-caveat/

Regards


Yes is good, the solution is added and deployed but i not see the column when i created the new column. (i not see in web page: filtered lookup (information from all site collection))

 

thanks

 

 

Coordinator
Jun 28, 2012 at 9:35 AM

Hi, in order to se the column you have to:

  • install the solution using powershell command Add-SPSolution
  • deploy the solution in your web application using the central administration > system settings > manager farm solutions
  • do an iisreset

regards

 

 

 

Jun 28, 2012 at 11:50 AM
PeppeDotNet wrote:

Hi, in order to se the column you have to:

  • install the solution using powershell command Add-SPSolution
  • deploy the solution in your web application using the central administration > system settings > manager farm solutions
  • do an iisreset

regards

 

 

 

The problem is solved. Sincerely, Thank you for your help and responsiveness.