Access Denied when creating new column.

Dec 29, 2010 at 12:35 PM

Hello,

I've used this solution on one farm but now I can't seem to get it working on another one. My account is farm administrator, site collection administrator, db_owner of the content and config databases and I still get 'Access Denied' when I choose the 'Filtered lookup' option on the create new column page. Any ideas?

Regards,

Martin

Coordinator
Dec 30, 2010 at 2:06 PM

Hi Martin. This is very strange.
Can you read the SharePoint log and post error details ?
Also, can you check file system permissions over .xml (into the /XML folder from the SharePoint root) file and .ascx (into the /CONTROLTEMPLATES folder from the SharePoint root) files of our field ?

Dec 30, 2010 at 3:00 PM

Hello Peppe,

Thanks for your response. There is nothing in the sharepoint logs as well as the windows event log. Permissions for the mentioned folders seem fine. Just in case I gave myself and the app pool account explicit full access to the whole 14 folder. Strange thing is that this works for me on two other farms but not on this one. I've been comparing stuff between them but can't find anything. 

Martin

Jan 4, 2011 at 7:34 AM

Anyone got ideas on this?

Coordinator
Jan 4, 2011 at 8:21 AM

Hi Martin.
You are using claim authentication ? Or the site collection is configured to allow anonymous access ?

Jan 4, 2011 at 8:43 AM

Hi,

No anonymous access. In the meantime I found this thread from the previous version:

http://filteredlookup.codeplex.com/Thread/View.aspx?ThreadId=51296

As advised I added myself directly as full access account but no luck. 

 

Martin

Jan 11, 2011 at 6:25 AM

Well I asked our administrator to test with domain admin and it worked. He successfully created a column but with my account I can't. I can't think of any permission I lack. Can you point me to what it might be?

Coordinator
Jan 11, 2011 at 10:54 AM

Hi Martin.
I don't know what is appened to your environment. I've tested the field in a default installation of sharepoint 2010, and i've not any access denied error.
When you see the access denied error page, you can click on the link "request access" and you can see what's the resource that you are trying to access, in the e-mail that sharepoint sends to the sharepoint administrator.
Also, can you try to view the security section of the event viewer ? so, we are completely sure that no error is logged in any of the sharepoint logs.

Peppe

Mar 13, 2012 at 2:20 PM

I had a similar problem. It worked without a hitch on our development server where I have Site Collection Administrator privileges, but errors as soon as I select Filtered Lookup when creating a column in our production site. Had to have the Site Collection Administrator grant me the same privilege to get it to work.

Any possibility of having this requirement removed?

Mar 22, 2012 at 3:42 PM

Morning

I just had our IT Install this, so was excited to add it.

After adding in a Column name and then clicking the radio button for the Filtered Lookup, I get he Access Denied screen without the option of being able to ask for request.

Is there a solution to this yet as we cannot keep having the IT guys add new columns for us.

Iain

Apr 12, 2012 at 12:16 AM

I am also having this same problem.

Any help with fixing it would be appreciated.

Thanks

Simon