Deployment in a Farm

Dec 7, 2010 at 3:58 PM

Hi myro, I need to know how is the best way to install your solution in a Farm, I have 2 front end servers and 2 aplication servers, will it work in this environment??

Thanks

Coordinator
Dec 7, 2010 at 6:07 PM

Hello canoriviera.
Yes, it will definitely work into your environment. You just need to install the SharePoint Solution (WSP) in the right way.
If this is your first time in installing a custom SharePoint Solution into your farm, you can get familiar by reading this article:

http://dev4side.com/community/technical-articles/sharepoint-2010/understand-and-manage-sharepoint-solutions-through-powershell.aspx

Here is what you should do:

  1. Download the wsp http://sp2010filteredlookup.codeplex.com/releases/view/
  2. Copy the wsp file in any of your farm's server ( feel free to use a front end if you want to)
  3. from the server where you have copied the wsp, click Start -> Microsoft SharePoint 2010 Products -> SharePoint 2010 Managment shell
  4. Now we can install the wsp through the the PowerShell window.
    First you need to upload the solution. Type Add-SPSolution "pathToDev4Side.SP2010.FilteredLookup.wsp" 
  5. And then simply deploy it. Type: Install-SPSolution -Identity Dev4Side.SP2010.FilteredLookup.wsp -WebApplication http://yourServerUrl/

Remember to run this PowerShell commands with the farm's administrator account.
Let me know if you are stuck :)

 

Cheers

Myro

 

Dec 8, 2010 at 7:33 AM
Edited Dec 8, 2010 at 7:45 AM

Sorry, deleted

Feb 28, 2011 at 9:23 AM

Hi myro,

I have deployed this wsp solution successfully. But i cant see this feature in the "manage site features" page in the home site to activate it. So i tried to install it in the site directly using the command you have given.
"Install-SPSolution -Identity Dev4Side.SP2010.FilteredLookup.wsp -WebApplication http://localhost/". 
I got the following error while doing this. 
"The solution "dev4side.sp2010.filteredlookup.wsp" needs to install assemblies in the Global Assembly Cache (GAC). If you fully trust this solution, use the -GACDeployment parameter to deploy" 

So i tried the way given in the bottom of this below link 

http://dev4side.com/projects/sharepoint-2010-filtered-lookup-field.aspx

Now also the same problem i cant se this feature in manage site features page to activate it in my site. Also when i try to create a new Filtered Lookup column, i can see this features is not activated in my home site. 

Please guide me to activate this feature in my site.

Kind Regards,

Dhileep. 

Coordinator
Mar 2, 2011 at 9:25 AM

Hello Dhileep.
There is no feature that needs to be activate whith this solution.
After installing thie solution into your sharepoint farm, you should be able to create new Filtered Lookup columns.

Have you tried to add this kind of column to a sharepoint list?

Mar 22, 2011 at 8:51 AM

Hi Myro,

Thanks a lot for your response and sorry for my delayed response, since i was on leave for last 20 days.

I have tried as you suggested. Its working great.

Thanks again.

Regards,
Dhileep. 

Coordinator
Mar 24, 2011 at 6:11 PM

You are welcome